post-page

WordPress Plugin Compatibility Checker

21
responses
by
 
on
June 4th, 2009
in
WordPress Plugins

The biggest headache users face before upgrading to a newer version of WordPress, is whether or not all their plugins will work with the new WordPress version.

I have seen lot of people delaying upgrading to a newer version because of this reason, the WordPress Codex does maintain a list of plugins that are compatible with different versions of WordPress, WordPress Plugin Compatibility Checker is a informational service which indexes plugins and provides compatibility checks.

This tool does provide with a way to check whether a plugin follows different things to determine compatibility, however use it only for informational purposes rather than using it as a tool to base your decision on upgrading WordPress, the WordPress codex for plugin compatibility document is definitely the best way to go.

plugin_compatibility_checker

The plugin compatibility checker currently indexes more than 7500 plugins, out of which 5040 plugins are fully compatible with WordPress 2.8.

There are several criteria’s used while determining if a plugin is compatible or not, some of which include minimum and maximum WordPress versions, whether the plugin is using hardcoded values of wp-content, whether the plugin is compatible with PHP4, whether it is directly connecting to the database without making use of the DB object provided by WordPress among other things.

plugin_not_compatible_reason

If you are a plugin developer, you can use this tool to see if there are any problems with the plugin.

This tool will definitely come in handy whenever you want to make a decision to upgrade to a newer version of WordPress. The compatibility results provided by this tool may not be exactly accurate, it should only be used for informational purposes, the plugin compatibility list provided by WordPress Codex is the best way to determine if a plugin will work with WordPress 2.8 or not. Thanks Alex

heading
heading
21
Responses

 

Comments

  1. Kenji (7 comments.) says:

    According to that site, most of the plugins I’m running under WP 2.7.1 are not compatible above WP 2.5. Hmm.

    • Keith Dsouza (82 comments.) says:

      @Kenji yes the compatibility checks may not be exactly accurate and must only be used for informational purpose, the WordPress Codex plugin compatibility document is the best way to determine if a plugin is compatible with WordPress version or not.

  2. Mark Ghosh (386 comments.) says:

    testing comments

  3. Webdev (11 comments.) says:

    Ohhoh … this is something I’ve been looking for a few times. Thank you for sharing!

  4. Kieran O'Shea (5 comments.) says:

    On the face of it this is a very useful tool but the PREP criteria governing the overall plugin status (red/green) is misleading at best.

    Just because a prepare statement hasn’t been used doesn’t mean a plugin is not compatible with 2.8, neither does it mean that the code is insecure (there are other valid methods of securing SQL statements).

    Likewise, there are plugins in that list shown as compatible from 1.5 up to 2.8 and showing as green. This is misleading too because the presence of the prepare statement would surely preclude the plugin working in WordPress versions earlier than 2.5

    All that being said, it *has* made me realise about the ability to move wp-content (how did I miss that!?) and I will be updating Calendar to make allowances for this ;)

    • Stu (3 comments.) says:

      You said:

      Just because a prepare statement hasn’t been used doesn’t mean…that the code is insecure (there are other valid methods of securing SQL statements).

      Technically you are correct that Plugin developers could all try to protect their plugin from SQL injection attacks in their own way.

      But have you actually looked at the source code of your average plugin? It’s hardly professional-level code. I wouldn’t trust most plugin developers to write secure code. Have a look through Bugtraq one day for WordPress plugin vulnerabilities.

      The solution to this problem is to encourage plugin developers to use a standard and well tested way of protecting against this type of attack (i.e. $wpdb->prepare). Naming and shaming of plugins that access the database without using the WP prepare statement function first is one way that we can do this.

      Cheers,
      Stu.

  5. George Serradinho (107 comments.) says:

    I never knew about this site, I will have to go and see if my plugins on my site are still ok. Thanks for sharing this.

  6. khaled (4 comments.) says:

    I think the list of plugins would be more useful as the plugin checker doesn’t seem to be up to date on some of the plugin information.

  7. Yves says:

    A big thank you to the author. I have been waiting for that for a long time. It would be great to have this automatted within the Plugin repository. Imagine a script going through the “active” plugins in the plugin page and notifying the maintainer that the next version of WordPress might not compatible (based on deprecated functuion and such)? Feedback while you upload your new plugin on whether proper WordPress function are used and so on… Think of the possibilities! What a progress!

    This tool, while not perfect this will make a huge difference.

  8. Shane Goldberg (1 comments.) says:

    Handly little tool ;) Thanks for sharing.

  9. WPEngineer (3 comments.) says:

    As Keith already mentioned, the results provided by this tool may not be exactly accurate, it should only be used for informational purposes and reference. The developer, as you can read on our post, is going to improve the compatibility checker. It would be great to see this as a reliable decision maker.

  10. Menno (1 comments.) says:

    Nice, How about compatability with WPMU?

  11. Microsoft Guy (13 comments.) says:

    Nice tool, seems like the PREP assessment is off though.


Tweetbacks

  1. blognews (blognews) (104 comments.) says:

    [planet wordpress]: Weblog Tools Collection: WordPress Plugin Compatibility Checker: The bigg.. http://tinyurl.com/q9elqc

  2. WordPressYes (WordPress Yes!) (94 comments.) says:

    WordPress Plugin Compatibility Checker: The biggest headache users face before upgrading to a newer version of W.. http://tinyurl.com/q9elqc

  3. wplinks (WP Links) (3 comments.) says:

    RT @blognews [planet wordpress]: Weblog Tools Collection: WordPress Plugin Compatibility Checker: The bigg.. http://tinyurl.com/q9elqc

  4. InariMedia (Inari) (7 comments.) says:

    WordPress Plugin Compatability Checker: http://tinyurl.com/q9elqc [WeblogTools]

  5. DanJagoHarrison (Dan Harrison) (1 comments.) says:

    Useful tool for wordpress plugin developers – WordPress Plugin Compatibility Checker http://tinyurl.com/q9elqc

  6. xeduarda (Ximena Eduarda) (8 comments.) says:

    #Wordpress plugin compatibility checker http://tinyurl.com/q9elqc

  7. alanpachuau (Alan Pachuau) (1 comments.) says:

    WordPress Plugin Compatibility Checker http://tinyurl.com/q9elqc


Trackbacks/Pingbacks

  1. […] alguns dias que li um post no Weblog tools collection com a indicação de uma lista com vários plugins para WordPres informando a compatibilidade […]

Obviously Powered by WordPress. © 2003-2013

page counter
css.php