post-page

WordPress Bids Farewell to PHP 4 and MySQL 4

10
responses
by
 
on
July 25th, 2010
in
WordPress, WordPress News

After five years of dedicated support, WordPress will be leaving PHP 4 and MySQL 4 behind for the far more current and secure PHP 5 and MySQL 5. WordPress 3.2, planned to launch during the first half of 2011, will be the first release to require PHP 5.2 or higher and MySQL 5.0.15 or higher.

The change really comes as no surprise. Both PHP 5 and MySQL 5 are far more secure than their predecessors and they are actively developed. How long has it been since an update was made to PHP 4 and MySQL 4? The final version of PHP 4 was released during August of 2008, followed by the final version of MySQL 4 on December of 2008. Both PHP 4 and MySQL 4 have been discontinued for almost two years.

The WordPress team is confident that the change in requirements will be relatively inconsequential. According to Mark Jaquith, “Only around 11 percent of WordPress installs are running on a PHP version below 5.2 [and] fewer than 6 percent of WordPress users are running MySQL 4.” Mr. Jaquith adds that most users running a PHP version less than 5.2 belong to hosting providers which actually support PHP 5.2 or higher. These users may have the ability to enabled PHP 5 via their hosting provider’s control panel or request to be moved to a server with PHP 5.2 or higher and MySQL 5.0.15 or higher.

Arguably, some hosting providers still swear by PHP 4 and MySQL 4, but considering that both Drupal and Joomla will sport similar requirements later this year, many will be forced to finally offer PHP 5 and MySQL 5. If your hosting provider insists on forcing you to use a PHP and MYSQL version that has been discontinued for almost two years, consider the cliché “there are many fish in the sea” and find a new hosting provider.

Hot on the heels of this announcement is the new Health Check plugin which will immediately confirm your server’s WordPress 3.2 compliance upon activation. The plugin will be receiving several additional features in the near future, but for now it should provide peace of mind for most of you regarding the impending change in WordPress’ requirements.

heading
heading
10
Responses

 

Comments

  1. quicoto (39 comments.) says:

    Some people says Automattic is nuts to force the users upgrade their servers.

    I think it’s ok. Most of shared hostings already have PHP 5.2 and Mysql 5

  2. Kirk M (67 comments.) says:

    I have to commend WordPress for supporting PHP 4 and MySQL 4 for so long. Far longer than they had to in my opinion although I can understand why. People can be awful stubborn about upgrading anything even when something has been deprecated for nearly two years. I often help those who are having troubles with their WP installs but I finally had to draw the line for those are still running old versions who can’t understand why the newest versions of a plugin doesn’t work with their install and who still refuse to upgrade. I actually had someone contact me who was still running WP 2.1.

    Here’s to a new generation of state of the art WordPress.

  3. Costin Lucian (1 comments.) says:

    it’s about time wordpress moves on

  4. Andrew @ Blogging Guide (86 comments.) says:

    I agree with Costin. If the change is for the better, then move one…

  5. Skills2Earn (1 comments.) says:

    I think wordpress decision is great, and it wont have any damage as most of the people are already using php 5 and mysql 5.

  6. Robert Pendleton (3 comments.) says:

    It is a really revolution for WordPress. It seems this shift may impose leverage on WordPress users and Internet development. Most of developers are using PHP 5 and My SQL 5 as well.

  7. Sam @ Dressrail (1 comments.) says:

    My hosting provider has upgraded their PHP and MySQL versions on a constant basis, although this affects some parts of my code, the PHP communities around the web have always been there to sort the problem out, Will the upgrade affect older plugins that rely heavily on PHP4? I guess the authors of the plugins will have to answer that!!

  8. Dave Doolin (25 comments.) says:

    As a developer writing in mid-2011, I need the the capabilities of 5.3 to keep my skills current with what developers in competing languages and frameworks are using. Sure, I get that users don’t care, and it costs hosting companies money to upgrade, but not keeping up with current technology affects my paycheck. Now, according to Wikipedia, PHP 5.2 is two years old, and no longer supported. WP is in a great position to “encourage” the move to PHP 5.3.



Trackbacks/Pingbacks

  1. […] position, and I am now trilled to announce that I was hired!  In fact, my first post detailing WordPress’ impending requirements change has just been published!  You can expect most of my WordPress-related posts to be published on […]

Obviously Powered by WordPress. © 2003-2013

page counter
css.php